化合物名の字訳（日本語名）

字訳ツール（JavaScript）

英名（アクセスキーは e）
和名（アクセスキーは j）
翻訳優先:（アクセスキーは h） ～ 例えば「ethyl acetate」⇒「酢酸エチル」
字訳優先:（アクセスキーは z） ～ 例えば「ethyl acetate」⇒「エチル アセタート」
（アクセスキーは c）

上の窓の中に英語名（ASCIIにない文字は変換されません！英字の大文字小文字はどちらでも可）を書くと、カーソルが離れた時、下の窓に字訳名が現われます。アクセスキーを使う時は、e で入力し、j で字訳されます。

ギリシア文字を使う時は、beta-alanine, eta-cyclopentadienyl, di-mu-thioxo のようにすることができます（字訳には関係ない部分ですから b-alanineのようにしてもかまいません）。もっともα,βでもよいかもしれません（ブラウザ依存？）。

日本化学会編「化合物命名法（補訂７版）」および文部省「学術用語集化学編（増訂２版）」を参考にして作成しています。しかし同じにできていない点もままあります。

実在する名称であるかどうかを判定する機能はありませんので、英名に実在しない名称を入力しても、和名は、機械的に変換した結果を示すだけです。また、あらゆる名称に対応しているわけでもありません。使用する際にはご注意下さい。

作者:貞廣知行 (さだひろ=ともゆき) (C) 2000-2021.
http://nomenclator.la.coocan.jp/chem/jiyaku/jiyaku.htm

これはフリーウェア（無償）です。また、改造しようとも関知しません。

バグ（不正確な字訳）は少なからず残っていると思います。使用する際にはご注意下さい。

このソフトについて

このソフトはC言語版がバグチェック（結果をサンプルとして同梱）を経た一応の正式版です。JavaScript版はCのソースからプリプロセス処理で作っています。もしかするとJavaScript版特有のバグがあるかもしれません（フォームに幾つも打ちこむのは大変なのでC言語版と同等の確認はしていません）。

ソースプログラムとサンプルのみで、バイナリは含みません。

変更履歴


/* [This file is written in Japanese (Shift-JIS)] */
history of jiyaku.c [C] - jiyaku.js [JavaScript]:

2.52 [2021-09-08] OSe-等を字訳しないようにした。
2.51 [2019-07-20] 幾つかの慣用名に対処。
2.50 [2014-11-09] noで終わる接頭辞の後にrhで始まる語が続く場合(not nor-h)。
2.49 [2014-10-12] 移転対応など。
2.48 [2014-03-23] 幾つかの用語に対処。
2.47 [2013-06-09] 幾つかの用語に対処。
2.46 [2012-01-28] hexenonic acid vs xenon(ic acid)。
2.45 [2011-12-26] -amide,-amine等の語尾の扱いで若干の修正。
2.44 [2011-10-16] 幾つかの用語に対処。
2.43 [2010-03-14] 幾つかの用語に対処。
2.42 [2009-09-15] creosotic ⇒ cresoticに修正。
2.41 [2009-09-13] 幾つかの用語に対処。
2.40 [2009-08-02] -micinは、elemicinを除き、-mycinと同様にマイシンと字訳する。
2.39 [2009-07-11] 幾つかの用語に対処。
2.38 [2008-07-09] telluret- (語末のeがない場合)の処理。
2.37 [2008-05-30] isatoic acidとnor-について。
2.36 [2008-05-05] 幾つかの用語に対処。
2.35 [2008-03-23] 幾つかの慣用名に対処。
2.34 [2008-03-22] 幾つかの慣用名に対処。
2.33 [2008-03-16] 内部処理の改善。strmatch(),chrmatch()を利用。
2.32 [2008-03-02] furanium, curanium等についての修正。
2.31 [2008-02-12] 幾つかの慣用名、一般語に対処。
2.30 [2008-02-10] 大文字略号＋小文字aseの組み合わせ(ATPase等)。
2.29 [2008-01-27] 三文字略号をなるべく字訳しないようにした。
2.28 [2008-01-06] -amato, medi- などについて修正。
2.27 [2007-11-18] ion(n+), ion(n-) の前の空白の扱いを変更。
2.26 [2007-09-23] -yl + ethion- について修正。
2.25 [2007-07-15] -yl, -ene などの前の母音追加について改善。
2.24 [2007-07-11] -ete + trit- の修正。
2.23 [2007-06-02] 接頭辞 -yliaについて。
2.22 [2007-05-27] -ylylidene, -ylylidyneなど。
2.21 [2007-05-19] JSはフォーム非依存の関数ライブラリとした。selenonaneの修正。
2.20 [2007-05-07] JavaScriptについて-iオプションをフォームから選択可能にした。
2.19 [2007-05-06] kauranium, -ylenonatoについての修正。
2.18 [2007-04-24] .cファイル中、(C)表示の微調整。
2.17 [2007-02-24] Salicylideneの字訳がうまくいかない場合があった。
2.16 [2007-01-27] 第一級から第四級の翻訳。
2.15 [2006-12-03] pelargonate (<pelargonic acid) と argonate (<argon) ほか。
2.14 [2006-10-07] barate (<barium) と ribarate (<ribaric acid<ribose) ほか。
2.13 [2006-03-25] 幾つかの慣用名に対処。
2.12 [2005-11-19] C言語版:全体または括弧の中に空白しかない場合の問題に対処。
2.11 [2005-11-12] cyanuric chlorideなど。
2.10 [2005-07-10] -ylan(e), -ylin(e), -yllin(e), -ylon(e) など。
2.09 [2005-06-26] 幾つかの慣用名、一般語に対処。
2.08 [2004-09-25] 幾つかの慣用名に対処。cisoid,transoidをイタリック扱いに。
2.07 [2004-08-08] 幾つかの慣用名に対処。
2.06 [2004-07-10] アルドン酸の半体系名（pentonic acid etc.）他幾つかの慣用名。
2.05 [2004-06-13] 幾つかの慣用名に対処。
2.04 [2004-05-29] 幾つかの慣用名に対処。
2.03 [2004-05-04] 縮合位置の記号が a を過ぎた場合 (e.g. stuvwxabcde)
2.02 [2004-04-10] aurate vs laurate。
2.01 [2004-04-01] thiopheneyl など。
2.00 [2003-09-15] 幾つかの慣用名に対処。
1.99 [2003-06-08] 字訳しない接頭辞（イタリック扱い）に gem-, vic- などを追加。
1.98 [2003-05-18] 未対処だった金属陰イオンに対処。
1.97 [2003-05-11] 幾つかの慣用名、一般語に対処。
1.96 [2003-04-26] 幾つかの慣用名、一般語に対処。
1.95 [2003-04-06] -ite は亜酸と関係ない場合、できるだけ字訳する。
1.94 [2003-04-06] 幾つかの慣用名、一般語に対処。
1.93 [2003-03-30] 幾つかの慣用名に対処。
1.92 [2003-03-23] 第一～塩 (stannous など)、第二～塩 (cupric など)、
                  重～酸塩 (bicarbonateなど) などに対応した。
1.91 [2003-03-22] -i オプション付きで glycerateなどが奇妙な変換をされていた。
1.90 [2003-03-16] -i オプション付きで carbazide が奇妙な変換をされていた。
1.89 [2003-03-16] -i オプション付きの場合、alkylammonium chloride,
                  aniline chloride などで陰イオン名を翻訳するようにした。
                  字訳名が必要なら -i なしで変換してください。
1.88 [2003-03-15] hyperoxide 超酸化物など無機の幾つかに対処。
1.87 [2003-02-22] -amoyl, -aniloyl などの対処。
1.86 [2003-01-27] arene, hetarene は未対処だった。aryl, aryne も改善した。
1.85 [2003-01-19] iod の判定の改善 (thiododecane 等)。
1.84 [2003-01-18] nona- の処理の改善。
1.83 [2003-01-18] phthalein. iodi/iodo の判定の改善.
1.82 [2003-01-13] etha-, nona- の処理の改善。
1.81 [2003-01-13] ceramide, folate 等いくつかの慣用名の処理がうまくなかった。
1.80 [2003-01-12] 「アルコール」「グリコール」の前の空白は落とす。
1.79 [2003-01-12] fulminate, perrhenate など。
1.78 [2003-01-09] 陰イオンに伴うhydrogenは倒置しないときヒドロゲンと字訳する。
1.77 [2003-01-07] aci-nitro など。
1.76 [2003-01-05] 無水酢酸等の特例的処理が大文字を受け付けていなかった。
1.75 [2003-01-05] pyrimidine, perimidine, -thione, -phane + -ene/yne.
1.74 [2003-01-05] 内部処理の改善 : cvtjapan() 辺り。
1.73 [2003-01-05] -selenon-, -lactam, hafnium など。
1.72 [2003-01-05] muon ミュオン、protium など。
1.71 [2003-01-04] 倒置の語間に空白を置く場合を増やした（例えば、
                  「酢酸エチル」vs.「酢酸 2-エチルヘキシル」）。
1.70 [2003-01-03] 内部処理の改善。bis- (etc.) + s-/h-/cy-.
1.66 [2003-01-02] 語末の -de の処理の改善。
1.65 [2003-01-02] -h, -v オプションで実行ファイルに関する情報を出すようにした。
1.64 [2003-01-02] 日本化学会「化合物命名法」補訂７版ではque クェ、quo クォ。
1.63 [2003-01-02] quinque の字訳。bis,tris等の処理の改善。
1.62 [2003-01-01] icos の処理を改善した。
1.61 [2003-01-01] cyanogen. ついでに -ogen はやはり基本的に字訳どおりとした。
1.60 [2002-12-28] 「桂皮酸」→「ケイ皮酸」。
1.59 [2002-12-27] hexyl, -ylene の処理がおかしくなっていた。
1.58 [2002-12-22] -uric acid の処理を改善。
1.57 [2002-12-21] -carbothialdehydeなど。
1.56 [2002-12-21] -sce- の処理がうまく動いていなかった。
1.55 [2002-08-10] 名称が -os で終わる場合の処理。
1.54 [2002-07-15] tryptophyllysine は tryptophyl-lysineとならねば。
1.53 [2002-06-09] stearyl, fumaryl はアリール基ではない。
1.52 [2002-03-24] antimonide 「アンチモン化物」綴りの間違いを訂正。
1.51 [2001-10-20] 高分子のco-, stat- など。psicose のバグ。
1.50 [2001-08-22] 入力をstdinにした。
1.45 [2001-05-20] 塩酸塩。
1.44 [2001-04-14] -ateの字訳の特例。
1.43 [2001-03-17] アミノ酸アニオンの字訳。
1.42 [2001-03-16] 内部的小変更。
1.41 [2001-03-14] 内部的小変更。
1.40 [2001-03-04] 改行で終わらないテキストファイルの読み込み。
1.33 [2001-02-15] moveacid()の変更。
1.32 [2001-02-10] ドキュメントの手入れ。
1.31 [2001-02-09] 1.30v.upで発生したバグの手直し。
1.30 [2001-02-09] C言語版で１行の字数制限をなくす。
1.24 [2001-02-08] 数詞の処理の改善。
1.23 [2001-02-01] icosa-/eicosa-の適切な処理。
1.22 [2001-01-31] phenethylの適切な処理。
1.21 [2001-01-31] s()でマッチしないときの無駄なコピーを回避。
1.20 [2001-01-26] 内部処理に使う文字 '~', '|', '_' が混入したとき
                  のための適切な処置をする。
1.17 [2001-01-26] -ylase, -hydrogenate。
1.16 [2001-01-26] アルコラートの判定の調整等。
1.15 [2001-01-24] オキソ酸の酸性塩（水素塩）の処理の改善。
1.14 [2001-01-23] Zinc bis(methyl sulfate)  ビス(硫酸メチル)亜鉛
                  のような二重の倒置を行う。
1.13 [2001-01-23] 一個の陰イオンも、倒置モードでは翻訳を試みる。
                  無水酢酸など４つの特例を取りこむ。
1.12 [2001-01-22] JavaScriptの誤りを修正。
1.11 [2001-01-22] 倒置しない塩類の陰イオンの翻訳。
1.10 [2001-01-21] spaninvert(), invert() 関数により
                  二元型命名法の翻訳を部分的に実装した。
1.02 [2001-01-20] 簡略版をつくるようにした。
1.01 [2001-01-19] 非ASCII文字をエスケープさせて表示可能にした。
1.00 [2001-01-19] C言語に移植。
---- [2001-01-17] 外部JavaScriptにした。"-ic acid" の字訳処理ほか。
---- [2001-01-16] -en, -yn, -ylの前の好音字 'a' の補充についての改善。
---- [2000-05-14] JavaScript版の公開開始。
.END.